compressor blade

Описание программного продукта в среде Unigraphics компрессорная лопатка.

Назначение.

Основное назначение программного комплекса "компрессорная лопатка" - перепрофилирование осевого компрессора.

Программный продукт дает возможность:

  • анализировать геометрические данные;

  • редактировать данные;

  • выполнять геометрические построения;

  • готовить данные для других программ.

В качестве исходных данных могут быть использованы как текстовые файлы определенных форматов, так и модели лопаток построенные в Unigraphics.

Методы анализа.

  1. Получение характеристик профилей: углы входа и выхода, установки, хорда, средняя линия, размер максимально вписанной окружности ...;

  2. Получение характеристик решетки профилей: густота ...;

  3. Изменение параметров профилей по высоте лопатки;

  4. Вычисление центров тяжести сечений профилей;

  5. Сравнение профилей, лопаток;

  6. Анализ гладкости кривых и поверхностей, построение графиков изменения кривизны.

Алгоритмы для редактирования.

Программный продукт дает возможность редактировать как отдельный профиль в составе пера лопатки, так и все профили одновременно. Методы редактирования лопатки включают в себя одновременное редактирование профилей примененные к каждому профилю лопатки независимо друг о друга и методы учитывающие взаимное влияние профилей.

Алгоритмы для редактирования профиля:

  • масштабирование;

  • перемещение;

  • поворот;

  • изменение лопаточных углов входа и выхода;

  • изменение радиусов входных кромок и радиуса максимальной вписанной в профиль окружности;

  • сглаживание профиля.

Далее приведены иллюстрации к работе последних трех методов по коррекции профилей. Красным цветом показан исходный профиль, а синим - отредактированный.

Алгоритмы для редактирования лопатки:

  • выравниванию пера лопатки;

  • сглаживание лопатки.

Геометрические построения.

  1. Алгоритм построения пера лопатки в виде твердого тела для расчетчиков и конструкторов;

  2. Построения различных геометрических примитивов для анализа и контроля характеристик профилей и исходных данных.

Разработал Натальченко Евгений Евгеньевич